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Exercise 2. 

PCB Design 

Aim of the measurement 

− Introducing to the PCB design 

− Creating a schematic of an analog circuit, making simulations on it and designing a 

Printed circuit board for it.  

Keywords 

Printed circuit board, Schematic, OrCAD 
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http://www.ece.rutgers.edu/~ece428/PCBs/Gramiccioni,%20T.%20-
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http://server.ibfriedrich.com/wiki/ibfwikien/images/d/da/PCB_Layout_Tutorial_e.pdf 

Measurement instruments: 

PC with a Demo version of OrCAD 9.1   

Important terms 

PCB 

PCB is a thin (usually 0,5-3 mm) board  made of fiberglass, composite epoxy, or other 

laminate material. Conductive pathways are etched or printed onto board, connecting 

different electronic components on the PCB. There are single sided (one copper layer), 

double sided (two copper layers) or multi-layer up to 10+ layers PCBs. Beside the 

conductive layer most PCBs contains solder mask layers (a thin lacquer-like layer of 

polymer that is usually applied to prevent solder bridges between closely spaced solder pads) 

and silk screen layers (displaying text information for soldering or application). 
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Circuit Schematic or Schematic 

The Schematic is the representation of the electronic system using abstract, graphic symbols. 

Drawing a Schematic is always the first step of designing a PCB. Usually PCB design 

softwares contain separate tools for Schematic and PCB design. Often a PCB is represented 

by multiple Schematic pages separated by functions, like power domain, analog signal 

domain, inputs/outputs.  

Components 

In a PCB designing system a component is described by two different representation. The 

first is a Schematic symbol, an abstract representation of the inputs and outputs of the 

component. The second is the a Layout part which contains information about the 

component’s mechanical size and the required copper footprint to solder the component onto 

the PCB. In many PCB design software more than one Schematic symbol can be connected 

to one Layout part. For example an integrated circuit represented by a Layout part can 

contain 8 pieces of inverters, which can be used as individual Schematic symbols. Usually 

there is also an opportunity to use a Schematic symbol with multiple Layout representation. 

For example the integrated IC used in the previous example can have different footprints (a 

surface mount version and a through-hole mounted version) described by its data sheet. 

Footprint 

The Footprint is a pattern and space on a PCB taken up by a component. Every Integrated 

circuits has one or more packaging type. Data sheets describes the possible packages with 

their dimensions, and recommended PCB footprint dimensions. Usually PCB design 

softwares contain a huge library with hundreds of footprints representing the PCB layout of 

the most widespread standard packages. 

Netlist 

Many PCB design software use a different component for PCB and Schematic design. The 

netlist connect these two software components describing the used circuits and their 

interconnects. 

PCB Layers 

Most of the PCBs are multilayer ones. Sort description of the most widespread layers: 

Mechanical layers: There can be multiple mechanical layers containing the mechanical 

dimensions of the PCB board and/or the dimensions of the IC packages. Mechanical layers 

can contain information about the drillings used on the PCB for through hole packages or for 

inter layer connections: VIAs (VIA is a conductive drill hole connecting two routing layers). 

Routing layers: Routing layers are used for representing component footprints and 

interconnects. Routing layers can be located on the top or bottom of the PCB or also can be 

an internal layer (without footprints of course). 

Ground Planes & Power Planes: Ground planes and power planes (in 4+ layer PCBs) are 

solid copper layers shorted to a fixed potential. These layers are very important for power 

distribution and solid grounding.  

Silkscreen Layers: Used for displaying human readable information to help the soldering 

process or application of the PCB. Can be used on both the top layer and on the bottom 

layer. 

Solder Mask Layers: Solder masks are thin lacquer-like layers of polymer those are usually 

applied to prevent solder bridges between closely spaced solder pads. Solder mask layers are 

used for SMD (surface mount) components, where the soldering is not manually performed. 

Back annotation 

©BME-VIK Only students attending the courses of Laboratory 2 (BMEVIMIA305) are allowed to download this file, and to 
make one printed copy of this guide. Other persons are prohibited to use this guide without the authors' written permission.



Laboratory 2.  Exercise 2. 

3 

Back annotation is used to propagate back the changes made on the PCB to the Schematic. 

For example if a component’s name is changed on the PCB design to sort the components 

and help the soldering process, then the result must be propagated back to the Schematic to 

maintain the integrity of the design. 

Gerber file 

The Gerber format is an vector image file format which is the de-facto standard used by 

printed circuit board (PCB) industry to describe the printed circuit board images. 

PCB design rules 

There are many rules and advices to design a good PCB. During the design it is also 

important to keep the rules given by the future manufacturer of the PCB. Some practices are 

given below: 

Check the precision limits of the selected manufacturer: keep the minimum routing width 

(usually 6 mils, but there are manufacturers with better precision), minimum distance 

between routes etc. In most of the PCB design softwares there are a design rule tool to check 

these limits. 

Use wider routs for power supply and ground: routing width effects the resistance of the 

track. Therefore tracks conducting significant amount of current should be wider to 

minimalise the voltage drop. 

Do not use 90 degree wire breaks: rout wires with obtuse angles (more than 135 degrees) to 

avoid reflections and manufacturing problems. 

Regularize the drill table: PCB designed by using standard library footprints can have many 

different types of drill holes. These drill holes many times differs only in 1 or 2 mils, 

therefore they should be aggregated which lowers the manufacturing time and cost. 

Solder mask: keeping outs should be 2-4 mil larger than the copper pads, because of the 

manufacturing process.  

Board outline: Do not place wires or holes very near to the board outline, because it can be 

damaged during the cutting process. 

Drill Holes: Always use a bigger hole than the diameter of the pin, because the hole 

galvanization process will result in a smaller hole. Data sheets usually contains the 

recommended drill hole size. 

Routing: For a two layer PCB try to rout horizontally on one of the layers and vertically on 

the other side.  

Laboratory exercises 

During this laboratory exercise a schematic will be created for the inverting amplifier 

examined at measurement 1. Using this schematic a time domain and a frequency domain 

simulations will be performed. After the successful simulations a PCB will be designed for 

the circuit. Before the laboratory exercises read 

http://en.wikipedia.org/wiki/Printed_circuit_board 

as a background. 

1. Creating a schematic in OrCAD Capture CIS 

A first step of creating a PCB is to draw circuit schematics. Start the Capture CIS program 

from the desktop. 
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As a first step create a new project: File->New->Project. Choose the Analog or Mixed-

Signal Circuit Wizard option (Figure 1.).  

 

Figure 1. Creating a new project 

After creating a project two file is generated: .opj file witch contains the project setting, and 

a .dsn file containing the schematic circuit and its properties. 

 

Figure 2. A new project in OrCAD 

In a new project there are two main windows. On the left corner there is the project window 

containing the files of the project. In this window under the .dsn file the schematic pages of 

the project can be seen (a project can contain multiple schematic pages). This window also 

contains some information about simulation setups and part libraries.  

The other page is a schematic page. The schematic of the inverting amplifier will be drawn 

here. First exercise is to draw the schematic shown on figure 3.  
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Figure 3. Schematic of an inverting amplifier 

 

To draw the schematic above, circuits should be added to the page. Use the Place->Part 

menu or the  icon at the right toolbar to do this. Selecting the part to place is done using 

the pop up menu. 

 

Figure 4. Selecting a part to place 

The selected part can be placed into the schematic page. It can be rotated (key r), mirrored 

(by using the right mouse button pop up menu) etc. The place part command can be aborted 

by hitting the Esc key. Wires can be added to the schematic page by using Place->Wire 

menu or  icon on the right toolbar. Instead of drawing very long wires a Place->Netalias 

( ) tool can be used to logically connect two wire fragment (wires with the same net alias 

are considered as connected). The net alias is also very useful to help drawing simulation 

results, so place a name IN to the input wire and OUT to the output wire of the operation 

amplifier.  

Place and connect all the parts shown on Figure 3. Not connected parts should be terminated 

by using  icon on the right toolbar. 
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Ground references can be added to the project by using Place->Ground or the appropriate 

icon on the toolbar. Always use the 0/Source ground, other ground icons could cause 

problems during simulations. 

The last step is to set the proper value of the schematic circuit parts. It can be done by double 

clicking on the values or by selecting the part and using the “Edit Properties” option from 

the right mouse click pop up menu. 

2. Making simulations 

Simulation setups can be created by using the PSpice->New Simulation Profil menu (note 

that the .dsn file should be selected on the left project window to access this menu). 

As a first step lets create a frequency domain simulation (Make sure that the Vac source is 

connected to the operational amplifier as an input). Use the PSpice->New Simulation Profil 

menu. Give a name to the simulation and set the parameters shown on Figure 5.  

 

Figure 5. Frequency domain simulation 

Start the simulation by using the PSpice->Run menu or the play button on the toolbar. A new 

empty result window will be opened Figure 6.  

 

Figure 6. Empty simulation result. 

Use the Trace->Add Trace to display results. Draw the amplitude and phase diagram use 

DB( V(OUT)/V(IN)) for the amplitude and P( V(OUT)/V(IN)) for the phase. 
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As a second step create a time domain simulation and draw the V(OUT) and V(IN) signals. 

3. Creating a netlist for the Layout editor 

After checking the schematic with simulation, time to create a PCB for the circuit. First step 

of PCB creation is adding footprints to schematic parts. Footprints can be look up from the 

Library manager of OrCAD Layout. Start OrCAD Layout Demo and use the Tools->Library 

manager menu. Footprints can be selected in this manager, and the name of the footprint can 

be simply copied out from here (Figure 7). 

 

Figure 7. Library manager. 

Selected footprints can be added to the schematic parts by using the part properties menu. 

Select the whole design and by using the right mouse click select the “Edit properties” 

options from the pop up menu (use the Parts sub title). In the properties window the PCB 

Footprint property contains the real physical footprint of the schematic part (Figure 8.). 

 

Figure 8. Adding PCB footprint properties. 

Use the following footprints: SM/R_0805 for resistors, SM/C_0805 for capacitors, and 

DIP.100/8/W.300/L.450 for the TL082 operation amplifier. Add connectors to the 

schematics for the Input, Output and for the Vcc, Vss, and GND. Add foortprints to this 

connectors too. Parts only represented in the simulations has a PSpiceOnly TRUE property. 

Make this property TRUE for the load resistor of the operating amplifier. 

After adding all the footprints use the Tools->Create Netlist menu and create a Layout 

netlist. This will create a netlist file witch make connection between the schematic editor and 

the Layout designer.   
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4. PCB Design 

Start the Layout Plus Demo. New project is created by using File->New menu. A new 

project is asking for the default configuration of the PCB to be designed. This default 

configuration contains default wire wide parameters default VIA drills, default system 

settings etc.  Select the DEFAULT.TCH from Program File\OrCAD\Layout_Plus\Data. 

After selecting the default configuration select the .mnl file created by the schematic editor. 

The next is a .max file, which is the new generated PCB design. 

The Layout designer will start with all of the footprint placed onto the deign sheet. 

As a next step select the system parameters by using Options->System Settings. The Display 

unit: mils, a Visible grid 100, other parameters 25. 

Place the components on the design sheet in a way to help the routing process (yellow lines 

indicate which components should be connected). For component placement use the  icon 

from the toolbar or the Tools->Components->Select Tool from the main menu.  

Connect the components by using the  icon from the toolbar. Try to make an optimal 

routing. When connecting Power or GND nets use wider wires comparing to the signal nets. 

A possible solutions is shown on  

 

Figure 9. An example layout configuration. 

After creating a suitable layout the next step is to prepare the PCB for manufacturing. The 

manufacturers use the so called Gerber files in their process. To creation of the Gerber files 

starts by the specification of the used layers. Usually for this design requires the following 

layers TOP, BOT (bottom), DRD (drill drawing) and SMB (soldermask bottom), SMT 

(soldermask top). The layers to be used for Gerber file creation can be specified at Options-

>Post Process Settings menu. After the specification, the Gerber file generation is a straight 

forward automatic process, which can be started by using the Auto->Run Post Process menu. 

©BME-VIK Only students attending the courses of Laboratory 2 (BMEVIMIA305) are allowed to download this file, and to 
make one printed copy of this guide. Other persons are prohibited to use this guide without the authors' written permission.


